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1 Desktop 

Desktop (Picture 1.1) is divided in a few sectors which are described in the following 

chapter.  

 

 

Picture 1.1 

1.1 Tool bar 

Tool bar (Picture 1.2) is the first of the Desktop sectors. It is right under the Main menu 

bar.  

 

Picture 1.2 

1.1.1 Record   

The first button on the Tools panel is the Record function. It launches MIDI notes 

recording to selected tracks (See 4.1). 

 

1.1.2 Play all  

Another function is Play all. It starts the playback of your song from the very 

beginning. 
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1.1.3 Play/Pause  

The third button is Play/Pause. It launches the playback of your project from a 

selected point. During the playback it can be paused with the same button (the icon 

changes accordingly). When the playback is resumed, it will continue from the point 

where it was paused.  

1.1.4 Stop  

You can stop the playback by clicking a Stop button. This will change the position of 

the playhead (vertical line designating the current position) to the point where the 

playback originally started. Clicking the Stop button for the second time in a row will 

move the playhead to the beginning of the song. 

1.1.5 Loop timeline selection  

When activated, playback will loop the bars selected on the time line (see 4.3.2). 

1.1.6 Metronome  

This toggle button activates/deactivates the metronome. Metronome clicks on the 

beats of the bar based on the current time signature. It is deactivated with another 

click on the button.  

 

1.1.7 Record from a selected point  

After the activation of this button you can record from the selected point during the 

next recording.  

1.1.8 Punch-in  

While Punch-in is switched on, you can record only in the selected sector (see 1.2). 
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1.1.9 Save the current project  

The current project is saved by pressing this button. The keyboard shortcut is Ctrl+S. 

 

1.1.10 Insert notes mode  

Mouse notes insertion mode is turned on when activated (see 4.1.1). 

 

1.1.11 Time indicator  

Time indicator shows the time of the current point in a song.  

 

1.1.12 Tempo settings  

The tempo of the project is made slower or faster by changing this setting. (The value 

1.0 is a default tempo. The value of 0.5 is a half of it and the value of 2 is two times 

faster than the default one.) This value is relative. The overall BPM is calculated as 

current BPM (see 1.2.1) multiplied by relative tempo. Use this to slow down the 

tempo during recording if it is too difficult to record in the full tempo or to 

experiment with the final tempo before exporting. 

1.2 Time line 

 

 

The Time line (also called meta track) shows the bar numbers and the current playhead 

position.  By left clicking on the axis you can choose the point from which you want 

to start playing or recording. Punch-in selection can be made using the two blue 

sliders (drag them to the desired location). A more detailed view of the time line grid 

(for instance with quarters or quavers) can be activated in the View tab in the Main 

menu by clicking on Grid. 
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1.2.1 Tempo change in the middle of the composition 

Tempo change can be also set on the Time line. By clicking on the Time line with the 

right mouse button a pop-up menu (Picture 1.3) is expanded.  

 

Picture 1.3 

A new window (Picture 1.4) is opened by clicking on Add tempo event.  

 

Picture 1.4 

Enter the new BPM (beats per minute) value and the time position where the change 

should occur. The first field is the index of the bar. The second is the beat position 

and the third is the MIDI division position within that beat. The last field is therefore 

not very important as you probably always want to place the tempo change aligned 

with some beat. If you do not exactly know what you are doing, always leave the last 

field empty. You should also see the tooltip if you hover over any field. After clicking 

Add the event is placed on the timeline. It is represented as a red flag pointing from 

the place it is located to the right. You can now drag the event with mouse if you 

need to change its location. Or you can right click the event and edit it with dialog. 

 

1.2.2 Time signature change in the middle of the composition 

Start similarly as if you want to change the tempo (see 1.2.1). Right click the timeline 

and select Add time signature event (Picture 1.3). Now you can see the window below 

(Picture 1.5): 
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Picture 1.5 

In the Time signature fields insert the numerator and denominator of the time 

signature fraction (e.g. 4/4, 3/4, 3/8 and so on…). The Division time setting is the 

same as in 1.2.1. Note that you should always place the time signature event at the 

beginning of some bar. Therefore only the first field should be filled in (yes, we will 

definitely make this more user friendly in the future releases), otherwise you can end 

up with some strange behaviour of the timeline. By clicking Add you confirm your 

settings and the event is placed to the specified point on the timeline. You can that 

edit it as described in 1.2.1. 

 

1.3 Track 

Tracks are placed below the timeline (Picture 1.6).   

 

 

Picture 1.6 

You can import the notes in the track (see 4.2) or record your own notes (see 4.1). 

Also you need to assign a register to the track. This tells the barrel organ which 

sound (register) to use for the track reproduction on playback. Use mouse wheel to 

zoom on the track (horizontal zoom) or Ctrl + Mouse wheel to zoom vertically (this 

affects the keyboard size on the left). Use Ctrl+Shift+T or Track→New in the main 

menu to add a new track. 

You can also duplicate the selected track with Ctrl+Shift+C (or 

Track→Duplicate), which will create the exact copy of the track only with different 

register. You can than reassign the register to what you need. This is useful if you 
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want to duplicate the same melody for two different barrel organ registers. Often you 

also want to duplicate the melody and transpose the track of a quint. 

You can delete the track with Ctrl+Shift+D or in the main menu. You can also 

do all the things described above and much more by right clicking the track header. 

(Picture 1.7)  

 

 

Picture 1.7 

 

Now let’s look at the track tool panel. 

 

1.3.1 Mute  

This toggle button deactivates the track for playback. That means this that muted 

track will be omitted when playing. Use this when searching for some mistake or if 

the track is irrelevant for what you do at the moment. Upon next click the track is 

activated again. 

 

1.3.2 Solo  

This puts the track to the solo mode. That means only this track will be audible 

during the playback. All the other tracks will be muted. Note however, that this does 

not affect their mute state. Solo state has just higher priority than mute. Only one 

track (or none) can be put to solo state at a time. 
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1.3.3 Record track  

Toggling this button to the on state puts the track to the recording mode. When you 

then start the recording by pressing the record button in the tool bar (see 1.1.1), notes 

will be recorded to this track. Otherwise recording has no effect on the track. You can 

record to multiple tracks at a time if that’s of any use to you, but you can as well 

record to one track and then copy the content to the other. Toggle the button back to 

off state to cancel the recording state of the track. 

 

1.3.4 Monitor track  

Tracks marked as monitor will be audible when recording. Basically this acts as the 

opposite of mute for recording. Mute affects only playback, monitor only recording. 

 

1.3.5 Choosing registers (instruments) 

To change the barrel organ register assigned to the track use the combo box right of 

the monitor toggle button. Click on the two small arrows and the list of usable 

registers will appear. 

 

 

Picture 1.8 

 

Choose whatever the register you want from the list (Picture 1.9). 

 

  

Picture 1.9 
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1.3.6 Track name   

You can rename the track by right clicking the track header and selecting the option 

rename track. This serves mostly as a label for your better orientation. Use descriptive 

names such as “solo”, “bass”, “main theme” and so on… 

 

1.3.7 Collapse/Expand track  

Use this toggle button to expand/collapse the track. Expanded track looks like the 

one depicted on the Picture 1.6. Of a collapsed track, only the header is visible. Use it 

to save the workspace when needed. You can collapse the tracks that you do not 

work with at the moment. You can collapse all the tracks at once by View->Collapse 

All. Similarly you can expand all the tracks at once. 

 

1.4 Audio mixer 

Audio mixer is located at the bottom of the program window, and can be hidden (to 

save the work space when needed) or shown using F3 key or in the View tab of the 

main menu bar. Use it to control the volume of individual tracks. 

 

 

Picture 1.10 

 

Drag the slider up or down to set the volume. Zero is the minimum (track completely 

muted), 127 is the maximum. 
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1.5 On screen keyboard 

On screen keyboard (Picture 1.11) is one of the possibilities (not a very good one 

though) to record notes to the track. 

 

 

Picture 1.11 

 

When you click any key of the keyboard the respective sound is played back. If you 

have the barrel organ connected and set up as a MIDI output, the keyboard will use 

the barrel organ register of the last selected track. If your MIDI output (see 3.2) is set 

to any synthesiser (typically Microsoft GS) you will hear a piano sound. The lower 

you click on the keyboard the louder the sound. 

 On screen keyboard is not a good tool for recording the track (see 4.1) for better 

options), but you can use it to find the tone you are thinking of when composing a 

song. 

 

 

2 New project 

 

Now that we know the basic functions, let’s create a new project. You can do this 

with Ctrl+N shortcut or File→New (Picture 2.1) in the main menu bar. A new project 

is also implicitly created when you launch the application. You can save your project 

with File→Save (Ctrl+S) and then later open it with File→Open (Ctrl+O).  

 

 

Picture 2.1 
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3 Settings 

Now we have our project all set up but we may need to look at the settings too. 

Settings are not project dependent and it should be enough to set the things up just 

once unless anything changes (e.g. we connect/disconnect our barrel organ). 

 

3.1 Language 

Use Settings->Language (Picture 3.1) to set the language you want. Currently 

supported languages are English, Czech and German. If your language is not 

supported, you can translate the program yourself by creating your own lang file (see 

e.g. german.lang in the installation folder on how to do it). If you see any language 

related problems (e.g. incorrect translation) please report the problem to 

flasipis@organ-service.cz. 

 

 

Picture 3.1 

 

English is the default language. If you check the use extension language pack option 

(Picture 3.2) you can select from the displayed languages. The language will change 

right after you click any item in the list. To revert back to English uncheck the use 

extension language pack checkbox. 

 

 

Picture 3.2 
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3.2 Input and output settings 

You can get to input and output settings by selecting Input/Output settings (Picture 

3.1) in the settings tab of the main menu or by Ctrl+Shift+A shortcut. A new window 

is opened (Picture 3.3). 

 

 

Picture 3.3 

 

You can ignore most of the options here. Important are Active MIDI inputs (your 

external MIDI keyboard) and MIDI Output (your barrel organ). Read more in the 

chapter 4.1.2.  

 

4 Work with MIDI 

There are four ways to get MIDI notes into our project. In this chapter we are going 

to explain how to do that, and also how to work with the project and MIDI events 

and how to export the final result of our work. 

 

4.1 Recording MIDI notes 

As explained in 1.5 you can use on screen keyboard to record the noted, but we do not 

recommend that. Instead use external MIDI controller/keyboard (see 4.1.2). You can 

also “click in” the notes directly to the place you want them to be in the track using 

the insert notes mode (see 4.1.1). 
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4.1.1 Insert notes mode 

Use this mode in the case you don’t have the MIDI keyboard with you. In many cases 

it is also easier to use this mode than any other (e.g. you need to fill in a few notes). 

There is also a great advantage of putting the note exactly where you want it. It is 

aligned with the displayed grid (see end of this section) so there is no recording 

error. Activate it on Tools tab (Picture 4.1) of the main menu or by pressing B key. 

There is also a pencil icon in the tool bar that lets you do the same. 

 

 

Picture 4.1 

 

After turning the mode on, your cursor should change to the pencil-like icon shown 

at the picture (Picture 4.2). Now click on the grid to place the note. 

 

 

Picture 4.2 

 

Exact note position and length are determined only by the displayed grid. To change 

these settings go to View->Grid and select the resolution you want. If you for 

example select quarters, all the notes you insert from now on will be quarters. If you 

select quavers, the grid will become twice as dense, and all the subsequently added 

notes will be quavers and so on… 
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4.1.2 Connecting external MIDI controller/keyboard and barrel organ 

First connect the device (most probably MIDI keyboard) to the computer and install 

the drivers supplied by the vendor. Now let’s launch Flašipis (if it is already running 

you may need to restart it to refresh the device list) and activate the device. Select 

Input/Output settings (Picture 4.3) from the settings tab of the main menu. 

 

 

Picture 4.3 

 

This will show the following window (Picture 4.4). 

 

 

Picture 4.4 

 

From the Active MIDI inputs box select the input device (MIDI keyboard) you want 

Flašipis to work with (Picture 4.4). From the MIDI Output list box select the MIDI 

output that is connected to your Organ Service barrel organ. You can work on your 

projects even without the barrel organ being connected but you will not hear the 

correct sound (determined by the selected register) it will make. When on the go, 

select Microsoft GS Wavetable Synth to replace the barrel organ sound for piano. 

Now close the window and you are ready to record.  
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4.2 MIDI import 

Yet another way to get MIDI events to your project is by importing a MIDI file 

downloaded from the internet or recorded with some other software. From the File 

tab of the main menu select Import. (Picture 4.5). 

 

Picture 4.5 

Alternatively you can also use Ctrl+I shortcut. If your current document has unsaved 

changes you will be prompted to save it.  After that the import dialog will appear 

(Picture 4.6). 

 

 

Picture 4.6 

 

Now select the file you want and confirm by clicking open. This will close the 

previous project and create a new one with imported tracks. MIDI file is split into 



16 

 

several tracks based on the channels, not tracks from the MIDI file (because of the 

way the barrel organ works). 

 

4.3 Editing MIDI notes 

Now that we have our project populated with some notes, let’s begin with some 

editing. 

 

4.3.1 Selecting notes  

You can select one or more notes in the track. To select a note, just click on it. It will 

turn green to indicate the selection. To select a group of coherent notes, click and 

hold some free place on the track and drag the mouse over the notes you want to 

select. The rectangular selection tool (Picture 4.7) will include all the notes contained 

within. You can easily check the notes that will be selected as they turn green when 

considered inside the selection. Once you are satisfied with the selection release the 

left mouse button and the notes are selected. To select a group of non-coherent notes, 

hold Ctrl key and click all the notes you want to select individually. To select all the 

notes in the track use Ctrl+A keyboard shortcut. You can also do this by right clicking 

the track header and clicking the select all notes option. 

  

 

Picture 4.7 
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4.3.2 Selecting bars 

Selecting a bar will also select all the notes that begin in the bar. You can do this by 

clicking on the grey bar with bar number located on the top of the piano roll (Picture 

4.8). You can select more consequent bars by clicking the first bar then pushing and 

holding the shift key and then clicking the last bar (Picture 4.9). 

 

 

Picture 4.8 

 

Picture 4.9 

 

If you need to select some bars in all the tracks at once, use the timeline for the 

selection. 

 

4.3.3 Shifting selected notes  

Having selected a note or a group of notes you can transpose them up or down using 

cursor keys up and down. Single ↑ or ↓ stroke will transpose the note a halftone. Use 

cursor keys left and right to shift the notes horizontally (in time). You can also click 

and hold a note or a one of the group of the selected notes and drag them to a place 

you want them to be. You can achieve both transposition and time shift with this 

function. To transpose a note by some standard interval, you can use Transpose 

submenu from the Tools tab of the main menu. When editing songs for the barrel 

organ, you will often need to transpose some track of an octave. Therefore learn to 

use the Page up / Page down shortcut to do this. Hit Ctrl+A to select the entire track 

and then push Page Up or Page Down to transpose the track. You can also transpose 

the entire track (without having to make the relevant selection) by right clicking the 

track header and selecting the desired interval from the transpose track submenus. 
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4.3.4 Copying and deleting notes 

To copy the selected notes use Ctrl+C shortcut. To insert them on a specific place, 

click somewhere in the track (not necessarily the same track you copy from) and hit 

Ctrl+V. This procedure will place the notes on the playhead position. To cut the 

selection use Ctrl+X. This will copy the notes to the clipboard and delete them from 

where they were. You can delete the selection by pushing the Delete key. You can 

also do all the above operations from the Edit tab of the main menu. 

 

4.3.5 Copying bars 

The difference between copy and paste functions of the notes and bars is that it 

behaves differently when pasting the selection. The copy/paste mode of bars is used 

if you have selected some bars. If the selection is notes only then the copy and paste 

mode for notes is used (see 4.3.4). The bar selection also contains the information 

about the selection length and can be used to shift the consequent bars instead of 

rewriting them (it will be explained further). You can copy the selected bars using 

Ctrl+C shortcut. You can then place them on some position shifting the rest of the 

track (meaning the bars at the paste position are not lost, only shifted) by selecting a 

single bar and hitting Ctrl+V. If you select more bars and launch the paste action, the 

selected bars are deleted and replaced by the bars you have copied. 

You can delete the selected bars by pushing the Delete key. This will only 

remove the notes within. To remove the bars completely shifting the rest of the track 

to the beginning of the selection (meaning there is now empty place left) use tools → 

selected bars→delete. 

You can insert empty bars to the track shifting the consequent bars (meaning 

they are not lost) by selecting the bars where you want to insert the new ones and the 

use tools → selected bars→Insert. This function is applied to all the selections in all the 

tracks. So if you want to insert the bars in just one track, make sure nothing else is 

selected. Often you may want to insert empty bars at some place in all the tracks. In 

this case select the bars in the timeline and then use the Insert function (see 4.3.2). 
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4.3.6 Notes length 

You can change the length of the selected notes with mouse wheel. Up to increase the 

length, down to shorten the note. 

 

4.3.7 Snapping the notes to the grid 

When recording the notes from the external keyboard you almost never hit the key 

exactly on time. You either hit it a bit sooner or a bit late. Humans are just not as 

precise as computers. If you need to fix this problem, you can use the snap function 

which will snap all the selected notes to the nearest “correct” position. Go to 

Tools→Snap and select the note length to which you want to snap to. Note that if the 

note is too short, it may be deleted completely. For example if you have a semiquaver 

note and choose to snap to quarters, both the note beginning and end align to the 

same position and therefore the note has zero length and will be automatically 

deleted. It is highly recommended to save the project before doing this action as the 

current Flašipis version does not support undo action. 

 

4.4 Export of a finished song 

Once you are satisfied with your project state, you can export it in the format for 

your barrel organ. Choose Export from the File tab (see Picture 4.10) of the main menu 

or hit Ctrl+E. 

 

Picture 4.10 
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In the Export window that gets opened navigate to the folder you want to store your 

exported file to and name the file using 3 digits, e.g. 320 (the first number defines the 

category of the song and the two others the order of the song within that category). 

Click the save button and you are done. Now you can copy the exported file to a 

memory card and insert it to your barrel organ. 


